MotoFan.Ru — все для Motorola > Разработчики > Мульти-функциональные программы > Bezols's P2KTools

Проблемы С Драйверами Полная версия
Страницы: 1, 2

 av Prodius

 28.5.2006, 18:30

При переключении в P2K режим система благополучно находит новое устройство, но упорно отказывается определять драйвера для тела в папке с драйверами. Принудительная установка выбраного драйвера тоже ничего не даёт, устанавливается только выбраный а остальные не находятся. Ковыряние реестра тоже ничего не даёт. Посоветуйте, что делать с этой проблемой?

Система Win Xp SP2

 no av AlexKorvin

 29.5.2006, 7:49

1. Не те дрова?
2. Вот ЭТО сделано?
Для установки драйвера под XP:
после подключения телефона запускаем regedit, находим ключ
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USB\Vid_22b8&Pid_3801\
Внутри есть ключ (в данном примере 5&28da0f34&0&1), настраиваем доступ:
Ставим галку Full control для Everyone:
В ключе находим значение Service, там стоит usbccgp, редактируем:
Изменяем на usbhub
Еще может быть подключ control, Там значение ActiveService, тоже изменяем.

 av Prodius

 29.5.2006, 16:42

2. А вот нет там такого ключа, и не появляется. Появляется Vid_22b8&Pid_4901 но никаких намёков на Service, control и пр там нет.

1. Вот это возможно, но дрова брал из комплекта Тулзов.

 no av AlexKorvin

 30.5.2006, 4:39

Цитата(Prodius @ Понедельник, 29 Май 2006, 19:42)
2. А вот нет там такого ключа, и не появляется. Появляется Vid_22b8&Pid_4901 но никаких намёков на Service, control и пр там нет.

1. Вот это возможно, но дрова брал из комплекта Тулзов.
*



Значит так. Делаешь следующее:
1. Подключаешь тело к компу.
2. Открываешь окно свойств системы, раскрываешь ветку "Контроллеры универсальной последовательной шины USB"
3. Запускаешь P2kTools.
4. В открытой в п.2 ветке при этом должно появиться новое "Составное USB устройство"
5. В сведениях смотришь код экземпляра устройства - это и есть ветка реестра.
6. Правишь реестр.
7. Выгружаешь P2kTools, отключаешь тело.
8. Снова подключаешь тело и грузишь P2kTools. Оно находит 3 новых устройства, ставишь дрова.
9. Испытываешь чувство глубокого удовлетворения... :-)

Все картинки - в прилагаемом файле.

 no av toltec

 30.5.2006, 17:16

Только сам собрался спросить о том же :)
Та же фигня. Однако есть нюансы:
дрова уже устанавливались и регистр для ХР СП1 правился нормально. Прога работала уже месяца 2-3. Потом установил дрова для блютус-адаптера чтоб подключить еще и К700i. На этом лафа закончилась :(

П2К находить телефон перестал. При переустановке составное USB-устройство не находит. В регистре соответствующие ключи естественно тоже. Точнее значение Service стоит не usbccgp, а Motorola, и ActiveService тоже не такой как нужно :)

Короче не весело, т.к. через блутус V3 тоже не подключается. Вобщем спецы или разработчики, прошу помощи...

 av Prodius

 30.5.2006, 17:31

Если бы так...
1. Подключаею тело к компу.
2. Открываею окно свойств системы, раскрываею ветку "Universal Serial Bus Controllers"
3. Запускаею P2kTools.
4. Шиш! Из нового появляется только новое устройство по прозвищу Motorola (V3r) которое мгновенно объявляет войну драйверам (см. скрин).

Хм, может тут собака порылась в том, что некоторое время назад к компу подрубалась Е398 (абсолютно корректно работав при этом)? А если так, то где искать эти рытвины?

 no av AlexKorvin

 31.5.2006, 4:22

Цитата(toltec @ Вторник, 30 Май 2006, 20:16)
Только сам собрался спросить о том же :)
Та же фигня. Однако есть нюансы:
дрова уже устанавливались и регистр для ХР СП1 правился нормально.
*



В твоем случае рекомендую догнаться до SP2. В мануале предпоследней версии P2KMan говорилось, что с SP1 присутствует трабла, которая не лечится. А трабла как раз и связана с множественным подключением USB-устройств.

Цитата(Prodius @ Вторник, 30 Май 2006, 20:31)
Хм, может тут собака порылась в том, что некоторое время назад к компу подрубалась Е398 (абсолютно корректно работав при этом)? А если так, то где искать эти рытвины?
*



Хм...
Тогда делай следующее:
Перегружайся в safe mode, ползи в реестр и в ветке HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USB ищи и уноси остатки 398 мотора. Должно выглядеть все тем-же образом - 3 ветки с похожими наименованиями, типа как на скрине внизу. Опять-же перед перезагрузкой посмотри в свойствах своей Motorola (V3r) код экземпляра и попробуй унести и его тоже нафиг. Я надеюсь 398 не по RS232 подключался? :-)
Потом на чистой системе все по новой.

 av Prodius

 2.6.2006, 10:05

Версия не прошла. На рабочей машине та же самая картина, учитывая что Е398 к ней никогда не подключалась... Может ещё мысли есть по этому поводу?

 no av AlexKorvin

 2.6.2006, 10:49

Тогда тебе остается последний вариант.
1. Выдираешь нах из машины все, что подключено по USB.
2. Тычешь тело. Оно определяется как Motorola (V3r).
3. В свойствах смотришь его код устройства и для него выполняешь все вышеописанное.

 av Prodius

 3.6.2006, 21:09

Не работает. Может всё-же что-то с версией прошивки или с "1. Не те дрова?" ?

 no av Werebear

 5.6.2006, 10:35

Попробуй драйвера из соседней ветки.
Мне по крайней мере с L7 помогло до этого примерно такиеже симтомы были.

 av Prodius

 11.7.2006, 21:16

Цитата(Werebear @ Понедельник, 5 Июня 2006, 12:35)
Попробуй драйвера из соседней ветки.
Мне по крайней мере с L7 помогло до этого примерно такиеже симтомы были.
*



Спасибо. Эти драйвера подхватил с одного пинка. ИМХО стоит об этом и в ФАК писануть.

 no av Klavish

 16.7.2006, 2:54

А можно теперь по русски написать?!?
У меня Razer V3 прошивка R374_G_0E.42.0ER ни Moto Mid Man, ни P2KTools2 не находят телефон. Пробовал заливать приложения Мидвэем, результат нулевой, вроде порт указываю верно, а выдаёт что нету соединения с телефоном и пишет что время истекло соединения.
Помогите, а то всю ночь парюсь над этой чортовой трубкой ничего не могу сделать)
Заранее благодарен. :(

 no av Jacks

 21.7.2006, 15:44

Цитата
4. Шиш! Из нового появляется только новое устройство по прозвищу Motorola (V3r) которое мгновенно объявляет войну драйверам (см. скрин).

У меня 2 телефона: Motorola V3r и Motorola V3.
Если есть у кого-нибудь motorola v3 без "r", подключи сначала её и установи дрова, а затем подключи свой. У меня сработало и работает без проблем теперь с обеими телефонами. Windows XP Pro SP2.

 no av alivak

 19.8.2006, 14:11

Цитата(Werebear @ Понедельник, 5 Июня 2006, 17:35)
Попробуй драйвера из соседней ветки.
Мне по крайней мере с L7 помогло до этого примерно такиеже симтомы были.
*



Огромное спасибо Werebear. Я с Motorola PEBL U6 все делал, только с бубном не плясал, а после установки рекомендованных дров [url=http://motofan.ru/board/index.php?act=Attach&type=post&id=51173], все заработало за секунду. clap;applo

 no av GeshaD

 14.9.2006, 14:17

А что делать, если есть только одна ветка в реестре - Vid_22b8&Pid_4902, а там только 5&6aff4e5&0&2, причём значение Service - Modem? И никак он дрова p2k не подхватывает и софтиной не связывается. Мало того - пробовал даже с компа, на котором всё работает перенести ветки реестра... Не работает! Что делать? Что мне вычистить в реестре или настройках компа (WinXP Rus SP2), чтоб заработало?..

Заранее примного благодарен!

 no av GeshaD

 15.9.2006, 13:11

Хочешь сделать что-то хорошо, сделай это сам. В который раз в этом убедился. Короче говоря информация для тех, кто пользует Bluetooth на компе. Реально его дрова и то кол-во COM-портов, которое генерится при установкеи софта к нему, очень не дружит с дровами для p2ktools. Снёс всё, что связано с Bluetooth, и заработала софтинка как положено (за исключение глюков, которые в ней по определению имеют место быть). Возможно теперь, если вновь установить дрова под Bluetooth, всё будет дружить... Не знаю - ещё не пробовал. Но думаю вышо изложенная инфа будет многим полезна.

 no av vies

 4.10.2006, 5:12

У меня телефон ROCR E1 . P2k его вообще не видит, хотя винда с памятью телеона работает нормально, но никаких новых драйверов ставить не хочет. Даже принудительно пишет что устройство в списке не обнаружено. ЧТО ДЕЛАТЬ? HELPPPPPPPPP!!!!!!!!!!

 no av voland666

 4.10.2006, 17:58

А я поставить смог дрова но только Java не ставиться вернее ставиться только потом перегружаю тел пытаюсь войти в Java а мне пишет мидлеты не установлены. Я просто уже в отчаянии :(

 no av McV

 6.10.2006, 15:43

Как я решал данную проблему для V3i:

1. Грохнуть все, что наставлено: "Составное USB устройство" и моторольный модем
2. Идем сюда:
http://developer.motorola.com/?path=1.2.6.30
и качаем оттуда "Motorola USB Driver" и "UID, KDWP and JAL Enabler Tool for Motorola OS Products Version 2.0"
Ставим сначала второе, потом первое.
3. Запускаем регедит и открываем ветку:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USB\
4. Запускаем "UID, KDWP and JAL Enabler", потом подрубаем телефон. Когда винда просит драйверы, указываем ей на папку:
"C:\Program Files\Motorola\UID Extraction Tool\drivers\Winxp\"
5. Скорее всего, инсталляция пройдет безуспешно.
6. Давим F5 в регедите и сечем какая НОВАЯ папка появилась в открытом разделе.
7. Для этой папки производим действия, описанные AlexKorvin-ом во втором посте этой темы
8. Снова запускаем "UID, KDWP and JAL Enabler", ффтыкаем тел, переустанавливаем дрова из тойже папки. Автоматом ставится еще куча дров.

Вроде все должно заработать.
Страницы: 1, 2

Полная версия:


MotoFan.ru (©) 2021    Слушать Radio